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Foot or right motor imagery 

This tutorial shows HOW-TO find and extract proper signal features from EEG data to separate 
epochs of EEG into distinct classes. The outcome is a classifier which can be used in real-time Brain-
Computer-Interface experiments. 

 
What is Brain-Computer-Interface? 
An Electroencephalogram based Brain-Computer-Interface (BCI) provides a new communication 
channel between the human brain and a computer. Patients who suffer from severe motor 
impairments (late stage of Amyothrophic Lateral Sclerosis (ALS), severe cerebral palsy, head trauma 
and spinal injuries) may use such a BCI system as an alternative form of communication by mental 
activity. 

 
Physiological background 
It is a well known phenomenon that EEG rhythmic activities, observed over motor and related areas of 
the brain, disappear about 1 second prior to a movement onset. Hence one can predict from the 
spatio-temporal EEG pattern that, for example, a hand movement will be performed. It has also been 
shown by various groups of researchers that this so-called desynchronized EEG is also observed for 
an imagination of a hand movement.  
The activation of hand area neurons either by the preparation for a real hand movement or by 
imagination of a hand movement is accompanied by a circumscribed ERD over the hand area.  
Depending on the type of motor imagery different EEG patterns can be obtained. Hence, one finds 
also a circumscribed ERD over the foot area in foot movement and foot imagination experiments. 
 
 

Experimental paradigm and recording setup for the BCI data acquisition 
Experimental paradigm 
The data set used for classification was acquired during a brain-computer interface experiment with 
feedback. The session was divided into 4 experimental runs of 40 trials with randomized directions of 
the cues (20 down and 20 right) and lasted about 1 hour (including electrode application, breaks 
between runs and experimental preparation). The subject sat in a comfortable armchair 1.5 meters in 
front of a computer-monitor and was instructed not to move, keep both arms and hands relaxed and to 
maintain the fixation at the center of the monitor throughout the experiment. 
 

 

 
Figure 1: Timing of one trial of the 
experiment with feedback. 

 
 
The experimental paradigm started with the display of a fixation cross that was shown in the center of 
a monitor. After two seconds a warning stimulus was given in form of a "beep". From second 3 until 
4.25 an arrow (cue stimulus), pointing down or to the right was shown on the monitor. The subject was 
instructed to imagine a foot or right hand movement depending on the direction of the arrow. Between 
second 4.25 and 8, the EEG was classified on-line and the classification result was translated into a 
feedback stimulus in form of a horizontal bar that appeared in the center of the monitor. If the person 
imagined a right movement the bar, varying in length, extended to the right and vice versa (correct 
classification assumed). The subject's task was to extend the bar toward the bottom or right boundary 
of the monitor as indicated by the arrow cue. One trial lasted 8 seconds and the time between two 
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trials was randomized in a range of 0.5 to 2.5 seconds to avoid adaptation (see figure 1 for the timing 
of the paradigm). 
 
EEG recording 
Two bipolar recordings overlaying the left and central sensorimotor area were placed on the subject's 
head as indicated in figure 2. The ground electrode was attached to the forehead.  
 

 

Figure 2: Montage of the 2 bipolar 
channels. Subjectôs nose points to 
the top of the page and the grid is 
viewed from above. Bipolar EEG 
electrodes (marked with dark green 
and light green) and the ground 
electrode (light green) are defined 
for further processing. The basis for 
the electrode positions is the 
extended international 10/20 
system. 

  
 

 
The amplified EEG was band pass filtered by an analog filter between 0.5 and 30 Hz and sampled at 
128 Hz. The resolution was 12 bits. A notch filter was used to suppress the 50 Hz power line 
interference. 
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1. Data Inspecting 
 
Running g.BSanalyze 

1. After starting MATLAB set the current directory to  

òMATLAB directory\ gtec \ gBSanalyze \ testdata \ bciò and start  ògBSanalyzeò  

in the MATLAB command line. 

 
 

2. g.BSanalyze starts with a blank data window 
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Loading and Viewing Data 

1. Select Load Data in the File menu  
 

2. Open the data-set by selecting session1.mat from the directory  
òYour MATLAB directory\ gtec \ gBSanalyze \ testdata \ bciò 

 

3. Enter a sampling frequency of 128 Hz  in the Enter Sampling Frequency window 

 
4. Press OK and the data are displayed 
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In the display section you can set the number of Seconds/Channels/Trials that should be displayed 
on the screen. Select 10 Seconds for the number of seconds on the screen and Goto second 40. 
Press on button S> for the status information. In this case the status information gives you a sampling 
frequency of 128 Hz, the total recording time of about 348.9141 seconds with 44661 data samples. 
The current data set has 1 trial and 3 channels (CH1, CH2 and the trigger TRG). 
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Channel configuration 

1. Select Channel Configuration in the Header menu  
 

2. Assign Name C3 to Chan. number 1 and choose Channeltype EEG 

Assign Name Cz to Chan. number 2 and choose Channeltype EEG 

Assign Name TRG to Chan. number 3 and choose Channeltype TRG 

 

 

 

3. Pressing OK yields 
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2. Merge Data 

A total of 4 so called runs were recorded and stored to disk under filenames session1.mat, 

session2.mat, session3.mat and session4.mat . Merging the 4 data sets together yields to 

160 (80 left hand and 80 foot) movement imaginations. For the further analysis of the data a 
concatenation of all runs is necessary. 

 

Perform the following steps: 

1. Select Merge in the menu Transform 
 

2. Press Select files é and choose session2.mat  
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3. Enter a sampling frequency of 128 Hz in the Enter Sampling Frequency window 
 

4. Repeat Steps 3 and Step 4 also for sessio n3.mat  and session4.mat  

 
5. Select Concatenate SAMPLES. Output preview shows the expected result of the merging 

process. Press the button OK. 
 

The new data-set consists now of 3 channels, 1 trial and about 4 times more samples as a single data-
set (176841 samples).  

See Status under the View menu. 
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3. Trigger Data 

For many calculations performed with biosignal data an epoching or triggering of data-sets is 
necessary. Therefore, a specific time marker or trigger channel with special events is required. The 
current data set has 160 TTL-trigger impulses on channel 3 which can be used to split the data into 
trials of equal length. 

1. Select Trigger in the Transform menu 
 

2. Define the Time before trigger as 2000  ms and Time after trigger as 6000  ms 

 
3. Select channel 3 in Physical channel as trigger channel and set the Threshold level to 90 % of 

maximum 
 

4. Select e.g. the name TRIGGER in Assign attribute to resulting trials and press button add to 
list -> 
 

5. Press Start! to perform the triggering 

 

 
 

The status bar in the editor windows shows the result: the number of trials is 160 and one trial has a 
length of 1024 samples. 
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4. Assign Attributes 

g.BSanalyze allows to assign channel attributes and trial attributes which are used for further 
calculations to include or exclude specific trials or channels. Trials with EOG, EMG or overflow 
artifacts can be marked with the trial attribute ARTIFACT to be excluded from further processing or 
with the attribute REMOVE to be deleted. Also channels, which are not relevant for further processing 
such as the trigger signal after triggering or channels with noise, can be marked with BAD to be 
excluded. On the other hand it is also possible to assign a trial attribute like RIGHT to indicate a right 
hand movement and to include only trials with the RIGHT attribute in further calculations.   

To assign attributes perform the following steps: 
 

1. Press Select in section MARKERS/ATTR. 
 

2. Click on Edit CHANNEL ATTRIBUTE and enter TRIGGER under Create new. Press the button 
Add to list. Click on button purple to assign a new color 
 

 
 

3. Close the window with OK ! 
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Assign the attribute TRIGGER to channel 3 by clicking onto the line that represents channel 3. The 

attribute TRIGGER is indicated at the left border of the window. 
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5. Load Class Information 
 

The Load Class Information window is used to assign trial attributes to the data from a given *.mat , 

or ASCII-file. The loaded class information vector must match the number of trials. Assume that you 
have loaded a data file with 3 trials into g.BSanalyze. An appropriate class information vector would be 
0 1 0. Load class information would assign an attribute to the second trial. 

1. Select Load class information from the File menu 
 

2. Click on the Import Wizard  

 
3. Search for the class information file class160.ma t  in the same directory. The Import Wizard 

shows the variables stored in the file and gives a truncated preview of the class information.  

 

 
 
4. Click Finish to assign the attributes to the data trials. The window shows the attribute name 4 for 

the first row of the loaded class matrix and 5 for the second row. 
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5. Select the new-loaded attribute 4, enter the attribute name RIGHT and click Assign Attribute. 

Click on 5 and assign the name FOOT. 

 

 
 

6. Close the window with OK. The attributes are assigned to your trials. 

The assignment of attributes to the trials can be seen if you change to the trial x channel mode 

in the section PRESENT in the Data Editor. As can be seen the session started with 3 foot movement 
imageries. The first trial with a right motor imagery is trial number 4. 
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6. Identify Reactive Frequency Components  
 

1. Select Spectrum of the Analyze menu 
 

2. Select 1000  ms as Length of interval to analyze 

 
3. Check Compute action spectra and compare to reference 

 

4. Set Reference interval starts at to 500  ms and Action interval starts at to 6000  ms 

 

5. Click on Select trials/chan. and exclude the channels with attribute TRIGGER from the 

following calculation. Confirm the settings and close the window with OK. 
 

6. Start the calculation with the Start button 
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As can be seen the subject has a prominent rhythmic activity around 14 ï 18 Hz over Cz which is 
different for action and reference period. However, differences can also be observed in the alpha 
band. The green line indicates the estimated power spectrum in the action interval and the blue line in 
the reference interval. The magenta lines at the top of the graphs display the significance level. The 
dotted lines represent the 95% significance level for the power differences.  
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7. ERD Analysis 
 
1. Open ERD under the Analyze menu entry 

 

2. Select a reference period of 500  to 1500  ms 

 

 
 
 
 

3. Click on Design filter and create a Butterworth  filter with order 5 and a lower cutoff frequency 

of 14  Hz and an upper cutoff frequency of 18  Hz. Assign the Name BETANEW, press add to 

list Ą  and press button OK 
 

4. Check Use filter and select BETANEW  

 

5. Click on Select trials/chan. and exclude the TRIGGER channel. Include only the FOOT trials. 

Close the window with OK 
 

6. Press OK to perform the calculation 
 

7. Repeat steps 5-6 and include only trials with the attribute RIGHT 
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The figure below shows ERD/ERS calculated between 14 and 18 Hz for trials with attribute FOOT. 

It can be seen that a very pronounced ERS can be observed over channel Cz. The blue graphs on top 
of the figures display the significance level of the ERD/ERS changes. The solid line indicates the 95% 
significance level. 

 
Channel 1, C3 Channel 2, Cz 

 
The figure below shows ERD/ERS calculated between 14 and 18 Hz for trials with attribute RIGHT. It 

can be seen that the subject shows an ERD over the contralateral area (C3) during the imagination of 
the right hand movement. 

 
Channel 1, C3 Channel 2, Cz 
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8. Feature Extraction 

This function of the Parameter Extraction menu computes the band power within a certain frequency 
range of the selected channels. The Band Power is estimated by digitally band pass filtering the data, 
squaring and averaging over consecutive samples according to the window length.  

Perform the following steps to calculate the Band Power: 

 
1. Click on Bandpower under the Parameter Extraction menu to open the following window: 
 

 
 
 
 
 

2. Select the created BETANEW filter  with the bandwidth of 14 to 18  Hz 

 

3. Specify the length of the estimation interval as 128  samples with overlap of 127  samples. 

Attention: No other overlap is allowed in the DEMO mode 
 

4. Click on select channels and add the EEG channels C3 and Cz to the list. Confirm the settings 
with the OK button 

 
5. Press Start to calculate the parameters 
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9. Data Set Classification 
 
1. Select Feature Matrix from menu Classification 

 

2. Set the classification interval to Start at 1000  ms, End at 8000  ms and Step to 500  ms 

 

3. Select as Class1 RIGHT and Class2 FOOT 

 
4. Click on Select feature channelsé and select channel 1 and 2 for classification 

 

5. Select Linear Discriminan t Analysis (LDA)  from the Classification method pull-down 

menu 
 

6. Press Start  
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The Linear Classifier window opens with the created feature matrix. The feature matrix contains 2 
features (channels 1 and 2), with 160 examples and 15 time points (1000, 1500, é 8000 ms). 
 

1. Select under Classification method Linear Discriminant Analysis (LDA)  and 10 x 10 

cross - validation  to randomly mix the training and testing data. 

 
2. Check Show with Result2D and Open classifier window 

 
3. Press Start 
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The classification results for RIGHT and FOOT movement imagery are given in the graph below. At 
the beginning of the trial the error is around 50%. After second 5 (arrow is show on the screen at 
second 3) the error drops down. The best error of about 16 % can be found at second 7 of the trial. 
This means that the data set can be classified with an accuracy of about 84 %.  
 
 

 
 
To further improve the classification result calculate also the bandpower in the alpha range of the 
EEG. Identify the optimal frequency range from the ERD analysis results. 

 
Reference: 

 
[Guger 2001] C. Guger, A. Schlögl, C. Neuper, D. Walterspacher, T. Strein, and G. Pfurtscheller, 
ĂRapid Prototyping of an EEG-based brain-computer interface (BCI),ñ IEEE Trans. Rehab. Engng., vol. 
9, 2001. 



 
 

Off-line EEG analysis of BCI experiments with MATLAB v2.12.01  23 

10. Batch Processing 

The easiest way to create a batch for data processing is to perform the analysis under the Data Editor 
with the graphical user interfaces. Make sure that the Show diary checkbox is enabled in 
Appearance Settings under the Options menu. 

 

 
This forces g.BSanalyze to report all calculations in the MATLAB command window. After finishing the 
analysis open a New M-file and copy and paste all commands into the file. 
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Save the batch in your own directory as mybatch.m  and start the batch under the MATLAB command 

window with  

mybatch  

  

For further data-sets just replace the input data file to perform the same analysis. 
 
 
Calling g.Result2d from the command line 

Analyze and classification methods produce specific objects that can be viewed with g.Result2d and 
stored to harddisk. To open such an object from the command line type 

 
R_O = CreateResult2D(A_O_S);  

to create a result2d object of the A_O_S (e.g. averaging object). 
 
then enter 

gResult2d(R_O);  

to view the object or 

gResult2d(R_O,ôprintô); 

to print the object. 
 
Starting g.BSanalyze from the command line 
 
To start g.BSanalyze from the MATLAB command line and to open immediately a file use 

dataedit(ófilenameô); 
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11. BCI Batch Processing 
 
Type into the MATLAB command window  
 

gbsanalyze  

 
to start the Data Editor. 
 

Load the acquired data file session1 .mat  for the calculation of a new weight vector for the next on-

line experiment with feedback. 
 
 

 
 
Then open the Appearance Settings window from the Options menu and browse for the user 
directory under 

 
Your MATLAB path: \ gtec \ gBSanalyze \ user  
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Confirm the settings by pressing OK. Now the User menu of g.BSanalyze is populated and contains 

the BCIBatch . 

 

 
 
Select the BCIBatch  to automatically process the data. Use the MATLAB editor to investigate or 

modify the processing steps.  

 

 
 

 
After a few seconds the analysis batch shows automatically a BCI experiment report containing a 
description of the BCI experiment and an error rate time curve. The best time point is indicated by a 
red circle. 

 




